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1. Introduction
Win X-12 is a Windows interface for X-12-ARIMA Version 0.3 (U.S. Census Bureau 2011).
This interface will:






Create the input files necessary for seasonally adjusting a series with X-12-ARIMA.
Run X-12-ARIMA and display the output files.
Create a data table with model information and diagnostics from series run in X-12ARIMA.
Create graphs from X-12-ARIMA output.

Return to index.
2. Requirements
Win X-12 has been tested on Windows XP, Windows Vista, and Windows 7. The program
requires that the .NET Framework 2.0 be installed on the computer. It can be downloaded here.
Win X-12 was designed to run X-12-ARIMA Version 0.3. Not all features will work if using
previous versions of X-12-ARIMA.
The interface can produce graphs in Java and in SAS. To produce the Java graphs, Java 1.6 or
higher must be installed on your computer. You can download the latest version of Java at
java.sun.com. To create graphs in SAS you must have SAS Version 8 or higher and the program
X-12-Graph Batch Version 1.4, which is available at http://www.census.gov/srd/www/x12graph/
(U.S. Census Bureau 2011).
Return to index.
3. Setup

Double click on WinX12.exe to start the Windows interface. The first time this program is run, a
Settings window will appear. The X-12-ARIMA Executable must be set before the interface is run;
all other settings are optional.
Win X-12 Settings
X-12-ARIMA executable: Enter the full path and filename, including the .exe extension, of the
X-12-ARIMA executable. (This is usually called x12a.exe.)
Convert output to HTML? The output file and log file, which by default are saved as text files
when X-12-ARIMA is run, can be converted to accessible HTML files using the HTML
converter, cnvout2html.exe. To save the output as HTML, select "Yes" from the drop-down
box, and enter the full path and filename of the HTML converter in the text box. By
default, the output files will be saved to the directory containing the spec file. To save the
output elsewhere, enter the new directory in the HTML output directory box.
Initial directory: Enter the directory containing your X-12-ARIMA input files. When Win X12 is started, the folder browser on the main screen will point to this directory. By default,
this control points to the Desktop.
Type of graph to create when run in graphics mode: When a spec file is run with X-12ARIMA in graphics mode, Win X-12 can create graphs from the series. If "Win X-12 Java
graphs" is selected, these graphs will be created using Java. This requires Java 1.6 or
higher. Select "X-12-Graph SAS graphs" to create these graphs using the X-12-Graph SAS
program. This requires that both SAS Version 8 or higher and the X-12-Graph Batch
program, Version 1.4, are installed on your computer. Enter the path of the latter program
in the X-12-Graph program directory text box. If "None" is selected, no graphs will be
created when a spec file is run in graphics mode. However, the graphics files will still be
saved, so you can create graphs later.
Default graphics path: Enter the directory to which graphics files should be saved when X-12-

ARIMA is run in graphics mode.
Program for opening text files: Check the Use default viewer box to open input and output
files within Win X-12. Note that when using the default viewer all open files will be closed
when Win X-12 is closed. To open and edit text files in an alternate text editor, deselect the
Use default viewer box and enter the full path and filename of the program's executable in
the text box. (For example, the program Notepad can be found in
C:\Windows\notepad.exe.)
Add time to X-12 run to compensate for network drive time discrepancies: You will likely not
have to use this. If your data is on a network drive and the output files or the diagnostics
window is not showing up after you run a spec file, it might be because the timestamp on
files written to the network drive is not in sync with that of the C drive. In this case,
checking the box and selecting a number greater than the number of seconds of discrepancy
can fix the problem.
Output file types to view: Select the file types you would like to be able to open with Win X12 on the main screen.
Press Save to save the settings and return to the main screen. To access this window again, go to
File -> Settings.
Return to index.
4. Win X-12 Main Screen

Use the Win X-12 main screen to open and run X-12-ARIMA input files and open the output
files, set the options for running X-12-ARIMA, and select the output to view when a spec file is
run.
Input Files: Running X-12-ARIMA

The three types of X-12-ARIMA input files are spec files, metafiles, and data metafiles. A
spec file contains the instructions for adjusting a series. These files, which have a .spc
extension, are described in Section 6. You can adjust more than one series during one X-12ARIMA run using a metafile, which is a list of spec files, or a data metafile, which is a list of
data files to be run using one spec file. These files have extensions .mta and .dta respectively,
and are described in Section 7.
To run X-12-ARIMA, use the folder browser in the top left to locate the folder containing the
spec file or metafile. All X-12-ARIMA input files will be shown in the input list box. Use the
drop-down box to filter the input files. To open the file FileName.ext for viewing or editing
before running it, select the file and press Ctrl+O, or select View -> View FileName.ext from
the menu. To run X-12-ARIMA, select the spec file, metafile, or data metafile, and press the
Run button or Ctrl+R. If you are running a data metafile, a new screen will appear prompting
you to choose the spec file corresponding to the data files listed in the metafile.
X-12-ARIMA Output Files
When X-12-ARIMA is run, a number of output files can be created. These generally have the
same name (or base name) as the spec file or metafile, unless an alternate output name is
specified, but have extensions based on the file type. Use the View Output Files drop-down
box to filter the output files by type. All files in the directory of that type will appear in the list
box; double click on the file you would like to open, or select it and use the View menu to
open it.
The output file types are:










*.err: Error file. X-12-ARIMA creates an error file for every series run. When it
encounters an error, it saves a description of the error to an OutputName.err file.
*.html: Optional accessible files. If X-12-ARIMA is run with the HTML converter, the
log file and output file are saved to accessible HTML files. See Section 5B for a
description. Win X-12 can also save certain output tables to HTML; see Section 5F.
*.log: Log file. A supplementary output file created when X-12-ARIMA is run, the log
file displays the diagnostics requested in the spec file using savelog arguments. See the
X-12-ARIMA documentation (U.S. Census Bureau 2011) for a complete list of savelog
arguments available.
*.out: Output file. The main output file created when X-12-ARIMA is run. The
information saved to the OutputName.out file can be controlled using print arguments in
the spec file; see the X-12-ARIMA documentation (U.S. Census Bureau 2011) for a
complete description.
*.udg: Diagnostics file. If X-12-ARIMA is run in summary mode or graphics mode, an
OutputName.udg file is created. See Section 8 for more details.

Runtime Options
Graphics mode: When the Run in graphics mode box is checked, X-12-ARIMA saves
graphics files to the path given in the Graphics directory box. If "Win X-12 Java graphs"
or "X-12-Graph SAS graphs" is selected as the Type of graph to create when run in
graphics mode in the Settings window, then the interface will produce these graphs when a
spec file is run. See Sections 5D and 5E for more information on the graphs. The graphics
files that are saved can also be used to create graphs later; the SAS program X-12-Graph
has a large number of graphs and graphing options available for this purpose.
Alternate output name: Check the New name for spec output box to specify an alternate name
for all program output. (This includes the log file, the output file, and all graphics files and

saved tables.) You can also use this option to provide an alternate output directory; in this
case, include the full path and the output name, even if you are using the same output name
as that of the input file.
Save original, trend, seasonal adjustment, and seasonal factors as HTML: When this box is
checked, up to four HTML files will be created when a spec or metafile is run, saving the
original series, trend (D12 table), seasonally adjusted series (D11 table), and the combined
seasonal factors and calendar effects (D16 table) to the output directory. See Section 5F for
more details.
Summary mode: Check Create summary file with diagnostics information or run X-12ARIMA in graphics mode to create the diagnostics file (*.udg file) when a spec or metafile
is run. The diagnostics file is saved to the graphics directory if Run in graphics mode is
checked, or to the output directory if it is not. If neither box is checked, the diagnostics
table will not be created when the spec is run.
Verify spec: When this box is checked, the spec file is checked for errors when it is run. Any
errors found are printed to the "Screen Output" tab of the Output screen. No further
processing of the spec is done.

Advanced Options: Further X-12-ARIMA options are available by pressing the Advanced
options button. In the window that appears, you can:








Suppress all output except for tables specifically requested in the spec file
Turn off pagination in the output file
Request a wide format in the output
Ask for reduced output
Run X-12-ARIMA in quiet mode, suppressing warnings sent to the console and printed
to the "Screen Output" tab
Sum components of a composite adjustment but adjust only the total

Win X-12 maintains the status of the check boxes--that is, all boxes that had been checked in
the previous run of the program will be checked the next time the interface is started.
Displaying X-12-ARIMA Output
Check the Output files box to display the log and output files when a spec or metafile is run.
See Sections 5A and 5B for details.
Check the Diagnostics box to display summary information from the spec file(s) processed in

a data table. See Section 5C for details.
Return to index.
5. Program Output
A. Text Output

When a spec file or metafile is run, the text output is, by default, shown in a window with
three tabs. The first tab shows the log file, containing the information requested in the spec file
with savelog arguments. The middle tab shows the output file, and the third tab the screen
output, which shows warning and error messages. If a metafile was run, there will be only one
log file, but each spec file will have its own output file. These output files can be accessed on
the Output tab using the drop-down box.
If an alternate Program for opening text files was provided in the Settings window, the log file
and screen output will be opened in that editor when the box requesting output files be shown
is checked. If a spec file is run, the output file will also be opened; the output files will not be
opened if a metafile is run.
B. HTML Output
If the output was converted to accessible HTML output, then when a spec file is run with the
output name OutputName, the following HTML files will be saved:




OutputName.html: The output file
OutputName_index.html: An index for the output file
OutputName_log.html: The log file




OutputName_log_index.html: An index for the log file
OutputName_err.html: The error file

The index and log index files are displayed when X-12-ARIMA is run; use the links they
contain to open the output and log files.
If a metafile is run, the output file, index file, and error file are produced for each series in the
metafile; OutputName is the name of the spec or its alternate output. One log file and log index
file are produced for all series in the metafile; OutputName is the name of the metafile or its
alternate output name. One additional file, OutputName_mta.html (or OutputName_dta.html if
running a data metafile), is also saved. This file contains links to each of the spec file's output,
index, and error files. When X-12-ARIMA is run, the *_mta.html or *_dta.html and
*_log_index.html files are shown. All other output files can be accessed through links on these
pages.
C. Diagnostics Tables

When the Diagnostics box on the main screen is checked, Win X-12 produces a Diagnostics
screen containing model information and diagnostics. The following tables describe the
information contained in the six tabs of the Diagnostics screen. These tables are also available
from within the Diagnostics screen by clicking on Diagnostics List from the Help menu.
"General" Data Table
Column Heading
Column Description
Series Name
Name of series. This is the name argument in the series spec, if given,
or the name of the output files otherwise.
View Spec File
Press the button to show the spec file that was used to adjust the series.
Only works if the row was added automatically when the series was
run.
Filename
Name of the output files
Period
Number of observations per year.
Transform
Transformation. Includes "**" if the transformation was automatically

Mode
Span
Seasonal Peaks
TD Peaks
SAdj Peaks
Irr Peaks
Resid Peaks
Ori Peaks

selected.
Seasonal adjustment mode. Includes "**" if the mode was
automatically selected.
Span of data adjusted.
Indicates whether the spectrum of the seasonally adjusted series,
irregular, or residuals has a visually significant seasonal peak.
Indicates whether the spectrum of the seasonally adjusted series,
irregular, or residuals has a visually significant trading day peak.
Indicates the visually significant seasonal and trading day peaks in the
spectrum of the seasonally adjusted series.
Indicates the visually significant seasonal and trading day peaks in the
spectrum of the irregular.
Indicates the visually significant seasonal and trading day peaks in the
spectrum of the model residuals.
Indicates the visually significant seasonal and trading day peaks in the
spectrum of the (possibly differenced, transformed, prior-adjusted)
original series.
"Model Info" Data Table

Column Heading
Column Description
Series Name
Name of series.
Model Span
Span of data used to estimate regARIMA model coefficients.
ARIMA Model
ARIMA model; "**" indicates the model was selected automatically by
the program.
Variance
ARIMA model variance.
Regressors
The regressors included in the model.
Trading Day
Trading day regressors included, with t-values if only one regressor and
p-values of the chi-squared test of groups of regressors if multiple
regressors; "**" indicates trading day was included based on results of
AIC test.
Holiday
Easter, Thanksgiving, or Labor Day regressors (with their t-values)
included; "**" indicates Easter was included based on results of AIC
test.
Seasonal
Seasonal or trigonometric seasonal regressors included, with the pvalue of the chi-squared test.
Constant
Gives the t-value of the constant, if it is included.
User
Gives t-values of user defined regressors included, and p-value of the
chi-squared test of the group of regressors, if there is more than one;
"**" indicates user regressors are included based on results of AIC test.
Coded Outliers
The outliers hard-coded in the spec file, with their t-values.
Phi1
Estimate of nonseasonal AR parameter at lag 1.
Sum NS AR
Sum of all nonseasonal AR parameter estimates.
Theta1
Estimate of nonseasonal MA parameter at lag 1.
Sum NS MA
Sum of all nonseasonal MA parameter estimates.
Sum Seas AR
Sum of all seasonal AR parameter estimates.
Sum Seas MA
Sum of all seasonal MA parameter estimates.

"Model Diagnostics" Data Table
Column Heading
Series Name
AICC
# Forecasts
Forecast mode
aa FcE (3-yr)
Normal?
# LBQ Fail
Sig LBQ
Sig Seas LBQ
# BPQ Fail
Sig BPQ
Sig Seas BPQ
Sig ACF
Sig Seas ACF
Sig PACF
Sig Seas PACF
Conv Tol
Maxiter
# Iter

Column Description
Name of series.
F-adjusted Akaike's Information Criterion.
Number of forecasted values.
Indicates whether forecasts are within sample or out of sample.
Average absolute percentage error of forecasts in the last three years.
Indicates whether residuals pass normality tests.
Number of lags from 1 to 24 with significant Ljung-Box Q statistic.
List of lags with significant LBQ.
Seasonal lags with significant LBQ.
Number of lags from 1 to 24 with significant Box-Pierce Q statistic.
List of lags with significant BPQ.
Seasonal lags with significant BPQ.
Lags with significant autocorrelation in the residuals.
Seasonal lags with significant autocorrelation in the residuals.
Lags with significant partial autocorrelation in the residuals.
Seasonal lags with significant partial autocorrelation in the residuals.
Convergence tolerance of the estimates.
Maximum number of iterations allowed.
Number of iterations to reach convergence.
"Outliers" Data Table

Column Heading
Column Description
Series Name
Name of series.
Outlier Span
Span of data checked for outliers.
AO Crit
Critical |t| for additive outliers; "*" indicates it was chosen by X-12ARIMA.
LS Crit
Critical |t| for level shifts; "*" indicates it was chosen by X-12-ARIMA.
TC Crit
Critical |t| for temporary change outliers; "*" indicates it was chosen by
X-12-ARIMA.
SO Crit
Critical |t| for seasonal outliers (SEATS only); "*" indicates it was
chosen by X-12-ARIMA.
# Outliers
Number of hard-coded and automatically selected outliers.
# Auto
Number of outliers automatically selected.
Auto Outliers
List of automatically selected outliers with their t-values.
"Stability Diagnostics" Data Table
Column Heading
Series Name
Rev Span
SA.AAR
MM.AAR
#Spans

Column Description
Name of series.
Span of data of revision history analysis.
Average absolute percent revisions of the seasonal adjustments.
Average absolute revision of the period-to-period percent change of the
adjustments.
Number of spans for sliding spans analysis.

Span Length
SF Cut
SF75p
SF%
SA Cut
SA75p
SA%
MM Cut
MM60p
MM%

TD Cut
TD75p
TD%
YY Cut
YY90p
YY%

Length of each span.
Threshold value for the seasonal factors.
75th percentile of maximum percent differences across spans of
seasonal factors.
Percent of months (quarters) with a maximum absolute percent change
of the seasonal factors greater than the threshold.
Threshold value for the seasonal adjustment values.
75th percentile of maximum percent differences across spans of the
seasonally adjusted series.
Percent of months (quarters) with a maximum absolute percent change
of the seasonal adjustment values greater than the threshold.
Threshold value for the period-to-period percent change in the
seasonally adjusted series.
60th percentile of maximum percent differences across spans of periodto-period changes in the seasonally adjusted series.
Percent of months (quarters) with a maximum absolute difference of
period-to-period change in the seasonally adjusted series greater than
the threshold.
Threshold value for trading day factors.
75th percentile of maximum percent differences across spans of trading
day factors.
Percent of months (quarters) with a maximum absolute percent change
of the trading day factors greater than the threshold.
Threshold value for the year-to-year change in the seasonally adjusted
series.
90th percentile of maximum percent differences across spans of yearto-year changes in the seasonally adjusted series.
Percent of months (quarters) with a maximum absolute difference of
year-to-year change in the seasonally adjusted series greater than the
threshold.
"x11" Data Table

Column Heading
Column Description
Series Name
Name of series.
M1
The relative contribution of the irregular over three months span.
M2
The relative contribution of the irregular component to the stationary
portion of the variance.
M3
The amount of period-to-period change in the irregular component as
compared to the amount of period-to- period change in the trend-cycle.
M4
The amount of autocorrelation in the irregular as described by the
average duration of run.
M5
The number of months it takes the change in the trend-cycle to surpass
the amount of change in the irregular.
M6
The amount of year-to-year change in the irregular as compared to the
amount of year-to-year change in the seasonal.
M7
The amount of moving seasonality present relative to the amount of
stable seasonality.
M8
The size of the fluctuations in the seasonal component throughout the

M9
M10
M11
Q
Q2
D8F
D8F p-val
Sigma Lim
Seasonal MA
Trend MA
I/S Ratio
I/C Ratio
MCD

whole series.
The average linear movement in the seasonal component.
As M8, calculated for recent years only.
As M9, calculated for recent years only.
A weighted average of M1-M11.
A weighted average of M1-M11 without M2.
F-statistic of test for seasonality assuming stability from D8 table.
p-value of D8 F statistic.
Lower and upper sigma limits for downweighting extreme values.
Seasonal moving average filter; "**" indicates the filter was chosen by
X-12-ARIMA.
Length of the final Henderson trend filter; "**" indicates the filter was
chosen by X-12-ARIMA.
The final irregular/seasonal Ratio from Table D10; also called the
global moving seasonality ratio.
The final irregular/trend ratio from Table D12.
Months for Cyclical Dominance

Win X-12 can flag rows which fail certain diagnostics. To choose the appearance of these
flagged series, select Table Styles from the File menu. From the window which appears, you
can choose the background color and text color of the row containing a failed or warned
diagnostic. Fonts can be set seperately for cells containing failed diagnostics, cells containing
warnings, and all other cells.
When saving a table as HTML, the colors marking the failed and warned rows will also be
saved if you choose Save Table With Formatting from the File menu. Customized cell styles
will not be saved; all failed cells with be bold and all warned cells will be italicized. To save
the table without any flags, select Save Table - Values Only from the File menu.

Selecting Failure/Warning Threshholds from the File menu will open a window which allows
you to choose the diagnostics warned against. For more information on X-12-ARIMA's
diagnostics, see the X-12-ARIMA Reference Manual (US Census Bureau 2011).
Win X-12 remembers the selections made for Table Styles and Diagnostic Threshholds. Once
the selections are made, they will always be used when Win X-12 is run.
D. Java Graphs
If "Win X-12 Java graphs" is selected in the Settings window as the Type of graph to create
when run in graphics mode, and the box for running in graphics mode is checked on the main
screen, then a new graph window will appear whenever a spec file is run. This window will
contain up to 10 graphs, depending on the options requested in the spec file. These graphs are:











Original Series
Logs of the Original Series
Overlay Graph of the Original Series, Seasonally Adjusted Series, and Trend
Spectrum of the Original Series
Spectrum of the RegARIMA Residuals
Spectrum of the Seasonally Adjusted Series
Spectrum of the Irregular
Seasonal Factors by Period
Seasonal Factors and SI Ratios by Period
ACF and PACF of the Residuals

If you right-click on any individual graph, a menu will appear allowing you to save the graph
as a .png file, print the graph, or adjust certain graph properties, such as changing some of the
graph colors or the title. For most graphs, the menu will also offer you zooming options. An
alternative method to zoom in on a portion of the graph is to move the mouse to the upper lefthand point of the region you would like to view, press the left mouse button, and, while
keeping the button pressed, move the mouse to the lower right-hand point of the region. When
you release the mouse button, the graph should zoom in to that region. Zoom back out by
repeating the procedure, but rather than moving the mouse down and to the right while the
button is depressed, move it in any other direction.

If a metafile is run, a new window will appear containing a list of the series contained in the
metafile. Select one or more series from the list and press Graph to create these graphs for the
series. (Note that a new window will appear for each series.)
E. SAS Graphs
If "X-12-Graph SAS graphs" is selected in the Settings window as the Type of graph to create
when run in graphics mode, and the box for running in graphics mode is checked on the main
screen, then when a spec file is run, Win X-12 will attempt to start SAS and run the X-12Graph program to create the ten graphs listed above. If a metafile is run, a new window will
appear containing a list of the series contained in the metafile. Select one or more series from
the list and press Graph to create these graphs for the series.
If the interface encounters a problem starting SAS, it will instead open the SAS program,
which is saved as x12graph.sas in the /appl subdirectory of the X-12-Graph program directory.
Run this program manually to create the graphs.
F. HTML Tables of Original Series, Trend, Seasonally Adjusted Series, and Seasonal Factors
If the box requesting the original series, trend, seasonally adjusted series, and seasonal factors
be saved as HTML is checked, then up to four HTML files will be created when a spec or
metafile is run. These files, called OutputName_Original.html, OutputName_Trend.html,
OutputName_SeasAdjSeries.html, and OutputName_SeasonalFactors.html, where
OutputName is the output name of the spec file or metafile, will be saved in the same directory
as the output file. The original series file will always be created; the other three will be created
if seasonal adjustment is successfully completed. The files correspond to tables A1, D12, D11,
and D16 of the output, respectively.
Return to index.
6. Creating New Spec Files

To create a new spec file for your data file, select Create -> Spec file from the menu. In the
window that appears, the only options that need to be specified are the data file, the data file
format, and the period. Pressing Create Spec will then write a spec file customized to your data
with:










The span and model span encompassing all the data in the file
The data checked for a log transformation and the result hard-coded
The series checked for flow trading day and Easter and the results hard-coded
The entire series checked for additive outliers and level shifts and the results hard-coded
An ARIMA model selected automatically and hard-coded
One year of forecasts
An X-11 seasonal adjustment with the seasonal filter hard-coded based on the global
moving seasonality ratio from the initial run
Sliding spans and history diagnostics with default settings

Alternately, you can customize these options, specify a prior adjustment file or user regressor, and
add metadata to your diagnostics file using the seven tabs in this window. The options available
through this interface are not the only options available in X-12-ARIMA; a complete list and
description is available in Chapter 7 of the X-12-ARIMA documentation (U.S. Census Bureau
2011). Once a basic spec has been created, you can open it in any text editor and edit it to
incorporate any additional options.
If you prefer alternate selections to be the default settings, you can set all options to your
preferences for the default selections and select Save Current Settings as Default from the File
menu. The selected settings will appear anytime you open this window until you change them or
select Clear Saved Default Settings from the File menu.

Win X-12 can create a spec for for each series listed in a data metafile. To do this, specify the
data metafile where the Data File or Data Metafile is requested in the Data tab. You can also
specify a metafile; however, as metafiles do not supply the extension of the data file, Win X-12
looks first for a file with a .dat extension, and if one is not found, for a file with a .txt extension. If
your data files have another extension, use a data metafile to create the spec files. If the data file
cannot be found, a default spec file with no data file will be created.
Win X-12 can also create a parent spec file for a composite adjustment and a spec file to be run
with a data metafile.
Data File Formats
You must specify the format of your data file. X-12-ARIMA reads data from text files,
generally with a .dat or .txt extension. The data can be in any of the following formats:











Datevalue: The file contains three columns- the year, the month (as a number) or
quarter, and the data value.
Free: The file contains just the data separated by one or more spaces or tabs or a new
line. To use this format, you must also provide the date of the first data point and the
period.
x12save: The format X-12-ARIMA uses to save data files. Use this format when using
an X-12-ARIMA output file as the input file.
tramo: The format the programs TRAMO and SEATS use to input data.
1L, 2L, 1R, 2R: Data formats originally used in X-11 and X-11-ARIMA. To use these
formats, the name specified in the file must be provided.
Fortran: A valid Fortran format, to be specified in the Fortran text box with opening and
closing parantheses.

X-12-ARIMA Dates
Dates in X-12-ARIMA spec files must be in yyyy.mmm, yyyy.mm, or yyyy.q format. The date
March 2008 would thus be either 2008.mar, 2008.03, or 2008.3; first quarter 2008 would be
2008.1.
Data Tab

Use the Data tab to choose the type of spec file to create, to specify the data file and the
location to which to save the spec file, and to set some series options.
Create individual spec files for each series: Check this box if you have a data file or data
metafile, and want to create a spec file customized for each data file.
In the Data file or data metafile box, enter the full path and filename of the data file,
metafile, or data metafile. Once a data file is entered in the box, you can open the file by
choosing View -> Data from the menu, or pressing Ctrl+D.
Enter the Name of new spec file in the specified box if you are creating a single spec file. If
you are creating spec files from a data metafile, the individual specs will have the same
filename as the data files, unless the Use alternate output name in metafile as the new spec
name box is checked. Then the interface looks for an alternate name for the spec file, and
possibly an alternate directory to which to save the spec file, in the data metafile. This
name must follow the data file name and extension on the same line.
Unless an alternate directory is specified in the data metafile, the spec file(s) will be saved
to the directory containing the data file. If you wish to later move the spec files to their own
directory, checking the box to Include the full path of the data file in the spec is necessary
so X-12-ARIMA can find the data.
Create a single spec to adjust all series in a data metafile: Check this box to create a spec that
can be used to run a data metafile. This spec will not reference a data file, and will
disregard all requests on subsequent tabs to hard-code results.
Enter the full path and file name of the spec file to be created in the Save new spec file as:
box.
Create a parent spec for a composite adjustment: Check this box to create a spec file
specifying the options for the direct adjustment of a composite run.

Enter the full path and file name of the spec file to be created in the Save new spec file as:
box.
Title: Enter a title for the spec. This is optional; if specified, it will be used on each page of the
program output, and as the title for any graphs created.
If you are creating multiple spec files from a metafile, you can enter a title for each
individual series by pressing the Title Options button. In the window which appears, you
can select to not specify a title, to use the same title for all spec files, to create an individual
title for each series by incorporating the series' name into a base title, or to specify a file
containing the titles for the series in the metafile.
Format: The format of the data file. See Data File Formats for more details.
Period: Choose "12" for monthly data, "4" for quarterly data, and "1" for annual data.
Span start and Span end: By default, all data in the data file will be analyzed. Use these two
boxes to limit the data used. If only the span start is specified, all data from this date to the
end will be used. Similarly, if only the span end is specified, all data from the beginning
until this date will be used. Dates must be in yyyy.mm or yyyy.q format.
Model span start and Model span end: By default, all data in the span will be used for
regARIMA model calculations. Use these two boxes to limit the data used to estimate the
regARIMA model. If only the span start is specified, all data from this date to the end will
be used. Similarly, if only the span end is specified, all data from the beginning until this
date will be used. Dates must be in yyyy.mm or yyyy.q format.
Prior Adjustments Tab

Use this tab to specify the transformation, regression variables, and outlier tests.

Transformation: Choose whether or not the data should be log transformed. Select Auto to let
X-12-ARIMA decide using an AIC test. (See Section 7.16 of the X-12-ARIMA
documentation for details of this test.) If the Hard-code transformation box is checked, X12-ARIMA will run to check for this transformation and write your spec file with the
result.
Regression: Trading day and Easter have different regression variables for flow series than for
stock series. If your series is a stock or inventory series, check the This is a stock series box
to use the stock version of these variables. Otherwise, the flow series version will be used.
(Note that X-12-ARIMA Version 0.3 does not have a stock Easter variable--later versions
of the program will.)
X-12-ARIMA can perform AIC Tests for trading day effects and Easter. By default,
checking the TD box will test for six-coefficient trading day if the series is a flow series.
For stock series, the variable tested by default is end-of-month stock trading day. If the
inventory is taken on another day, check the Flow Trading Day box below and specify the
day in the drop down box that appears.
To test for another trading day regressor available in X-12-ARIMA, check the TD box and
specify the variable in the Other Variables box.
By default, checking the Easter AIC Test box tests for Easter with a one-, eight-, and 15day window. To test only one of these, also check the Regression Variables Easter box, and
specify the window in the drop-down box.
Checking the Hard-code AIC results box will run X-12-ARIMA with the AIC tests
selected, and then write your spec file with the results.
To include flow trading day, stock trading day, a constant, or an Easter effect, check the
appropriate boxes. Any other regression variable available in X-12-ARIMA can be written
into the Other variables box. See Section 7.13 of the X-12-ARIMA documentation for a
complete list and description of these regressors.
Outliers: X-12-ARIMA can look for additive outliers, level shifts, and temporary change
outliers. Check the AO, LS, or TC box to search for each type. If Hard-code outliers is
checked, X-12-ARIMA will run, and any outliers found will be written into the regression
spec of your spec file.
LS run: Choosing a value greater than one from the drop-down box will request that any
successive run of up to that many level shifts be tested as to whether it is a temporary level
shift. A table with these results will be printed to the output file.
Span start and Span end: By default, the entire span of data specified in the model span will be
searched for outliers. Use these boxes to shorten this span. Dates must be in yyyy.mm or
yyyy.q format.
Prior Adj File Tab

You can use this tab to specify a file of prior adjustments.
Prior adjustment file: Enter the full path and file name of the prior adjustment file. This file
can then be viewed by choosing View -> Prior Adjustment File from the menu, or pressing
Ctrl+A.
Format: Specify the format of the prior adjustment file. See Data File Formats for details.
Mode: Specify whether the factors are percents or ratios, to be divided out of the series, or
values to be subtracted from the original series. Ratios or percent factors can only be used
with log-transformed data, and subtracted factors with no transformation. The program will
choose the transformation for the series based on the Mode selected here, ignoring your
transformation choice on the Prior Adjustments tab.
ARIMA Model Tab

Use the ARIMA Model tab to set the ARIMA model or ask X-12-ARIMA to automatically
find the model, to request ACF and PACF plots of the original series for model identification
purposes, and to set the number of forecasts.
Select model automatically: If the Hard-code automodel selection box is checked, X-12ARIMA will be run with the automatic modeling (automdl{}) spec with default settings,
and your spec file will be written indicating the model chosen. Otherwise, the spec file will
be written with the automdl{} spec. See Section 7.2 of the X-12-ARIMA documentation
for details on this procedure.
Use ARIMA model specified: To specify an ARIMA model for your spec file, enter it into the
ARIMA model box.
Identify model using ACF and PACF plots: Check the Identify model box and select one or
more differences and seasonal differences from the list boxes to create an ACF and PACF
plot of each combination of difference and seasonal difference selected.
Forecasts: Choose how many years of forecasts to create. Choosing Half filter length will
forecast for half the length of the seasonal filter, if either the filter or "Hard-code Global
MSR" is selected on the Seasonal Adjustment tab; otherwise, one year of forecasts will be
produced.
User Regressors Tab

Use this tab to input a user-defined regressor from a data set.
Data file: Enter the data file containing the user regressors. Only one file can be specified, but
it can contain up to 52 regressors. To view the file, choose View -> User Regressors from
the menu, or press Ctrl+R.
Format: Specify the format of the user regressor file. See Data File Formats for details. If the
file contains more than one user regressor, give the value for each regressor for a date
before moving on to the next date. That is, in the "Datevalue" format, the file should
contain a column for the year, one for the month, and then a column for each user regressor
for that date.
How many regressors are in the file?: Choose the number of user regressors in the file.
Name and Type: Each user regressor can have a name and type specified. By default, the name
is "user#", and the type "user." To change these for a regressor, select that regressor from
the list box. Type the new name into the Name box, and choose the type from the dropdown box. You must press Update to save these changes.
Seasonal Adjustment Tab

Use this tab to choose the type of adjustment and the seasonal filter. You can also choose to
include the history and sliding spans diagnostics, and tell the program how to include the
series in an aggregate, if the spec file is for a series that will be combined with others to create
a composite series.
Type of adjustment: Select x11 to perform an X-11 seasonal adjustment. Select Trading day
and holiday adjustment only to adjust the series only for calendar effects, not seasonality.
x11 filter options: Use the drop-down box to select the seasonal filter for the seasonal
adjustment. Choose "3x3," "3x5," or "3x9" to use that filter for all X-11 iterations. Select
"Global MSR" to let the program choose a 3x3, 3x5, or 3x9 filter for the final iteration
depending on the global moving seasonality ratio. Selecting "Hard-code Global MSR" will
result in X-12-ARIMA running, using the Global MSR to choose the seasonal filter, and
then writing your spec file with the chosen filter hard-coded. The "x11 default" filter is the
default filter from previous versions of X-12-ARIMA; it uses 3x3 filters for the initial
seasonal factors and 3x5 filters for the final seasonal factors in each iteration.
How should the series be combined into the aggregate? If the spec file is being created for a
series that will not be combined into an aggregate, select "Series is not part of an
aggregate." Otherwise, choose to add, subtract, multiply, or divide the series into the
aggregate or to ignore the series when creating the aggregate.
Stability diagnostics: Specify whether to calculate sliding spans and history diagnostics. An
optional box is included to specify the start date for the revisions history analysis. Dates
must be in yyyy.mm or yyyy.q format.
Metadata Tab

When X-12-ARIMA is run in summary mode or graphics mode, a diagnostics file with model
information and diagnostics is created. To include additional information in this file, enter a
description in the "Key" column, and the value in the "Value" column. For example, if you
type Adjuster into the "Key" column, and "John Smith" into the "Value" column, then
metadata.Adjuster: John Smith
will be included in the .udg file.
If you press the Save button after entering the keys and values, these columns will be saved
and included every time a spec file is produced. Press the Clear Metadata button the next time
you create a spec file to delete the stored metadata information.
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7. Creating New Metafile/Data Metafile
You can process multiple specs in one run using metafiles or data metafiles. A metafile is a list of
the spec files to run. A data metafile is a list of data files, which are all run using the same spec
file.
Metafiles are also used to adjust composite series. In this case, the spec files of the individual
series should be listed first, and the parent spec file listed last.
Creating Metafiles With Win X-12

To create a new metafile using the interface, select Create -> Metafile from the menu on the main
screen. In the window that appears, select the directory containing the spec files from the folder
browser. Select the spec files to include from the list box and enter a name for the new metafile in
the text box.
If you are running a composite adjustment, choose the parent file (the spec file that contains the
composite{} spec) from the drop-down box. To route the program output to an alternate
directory, enter this new directory in the text box provided.
Press Create metafile. The new metafile will be saved to the same directory as the spec files.
Creating Data Metafiles With Win X-12
To create a new data metafile using the interface, select Create -> Data metafile from the menu on
the main screen. In the window that appears, select the directory containing the data files from the
folder browser. Use the drop-down box to choose the extension of the data files. All files with
that extension will be added to the list box; select the files to include in the metafile.
To route the program output to an alternate directory, enter this new directory in the text box
provided.
Press Create metafile. The new data metafile will be saved to the same directory as the spec files.
Win X-12 Limitations: Creating Metafiles by Hand
The interface can be used to create a metafile when all the files to include are in the same
directory, and program output has the same name as the spec or data file. If you need a metafile
for spec files across different directories, or want to specify an alternate output name, you must
create or edit the metafile by hand. The following is a list of things to keep in mind when doing
so:



Metafiles have a .mta extension. Data metafiles have a .dta extension.
Do not include the .spc extension for the spec files. The extension of the data files listed
must be included in the data metafile.










Only one spec file or data file can be on a line.
If the spec file or data file is not in the same directory as the metafile, include the full path
and filename of the file.
To specify an alternate name for the output, include it on the same line as the spec or data
file. To specify an alternate path, include the path and the output name (even if you are not
renaming the output) on the same line as the spec or data file.
If the path or filename of the input has spaces, it must be enclosed in quotation marks.
Similarly, if the path or filename of the output has spaces, it must be enclosed in quotation
marks.
If you are running a composite adjustment, the composite spec file must be the last spec.

For more information on creating metafiles, see Section 2.4 of the X-12-ARIMA documentation
(U.S. Census Bureau 2011).
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8. Creating Diagnostics and Graphs From Previously Run Series
The diagnostics tables and graphs described in Sections 6C, 6D, and 6E can be created using
previously run spec files.
To create the diagnostics table, the spec file had to be run in summary mode (with Create
summary file with diagnostics information checked) or in graphics mode. If the spec file is run in
graphics mode, the diagnostics file (.udg file) will be saved to the graphics directory. Otherwise,
if run in summary mode, the diagnostics file will be saved to the same directory as the program
output.
From the menu on the main screen, select Create -> Diagnostics. Enter the directory containing
the diagnostics file in the Summary file directory box, select the .udg files to add to the
diagnostics table, and press OK. Alternately, if you'd like to add all the series listed in a metafile
to the diagnostics table, enter the directory of the metafile in the Summary file directory box.
Choose "Metafiles" from the drop-down box, select the metafile from the list, and press OK. If
the metafile contains an alternate output directory, the program will look in that directory for
the .udg file. Otherwise, it will look in the directory containing the metafile. If you ran the
metafile in graphics mode, the .udg files will be in the graphics directory, which in most cases is
different from the metafile's directory; copy the metafile to the graphics directory before trying to
create diagnostics.
If a series was run in graphics mode, you can create Java or SAS graphs by choosing Create ->
Graph from the menu of the main screen.
If Java graphs are selected from the Settings window, a new window will appear. Enter the
graphics directory in the box provided. You can select the series to graph from the list box, and
check the boxes for the graphs to create. A new graph window will appear for each series
containing all the graphs checked, if applicable to the series.
If SAS graphs are selected from the Settings window, then choosing Create -> Graph from the
menu will start the X-12-Graph interface. Creating graphs with this interface requires more effort,
but there are more graphs and graph options available than with the Java graphs. See the X-12Graph documentation (U.S. Census Bureau 2011) for complete details of the program.
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9. Deleting X-12 Files
X-12-ARIMA can produce many output files when running a series. You can use the interface to
delete them once you no longer need them.

To open this screen, go to File -> Delete X-12-Files in the menu. Use the folder browser to select
the directory containing the files to be deleted. The interface will list the names of the X-12 files
found, without the extension, in the list box on the right. All the extensions from these files will
be listed in the box on the bottom. In the file name list box, check the boxes next to the files to be
deleted. In the extensions list box, deselect any file extensions to keep. For example, if your data
is called MyData.dat, the spec file is MyData.spc, and the output files MyData.out, MyData.log,
MyData.err, and MyData.udg are in the directory, checking "MyData" in the file name box and
deselecting "*.dat" in the extension list box will delete all files except the data file.
Pressing Delete opens a screen listing all the files, with the extensions, that will be deleted. Press
Delete to confirm the file deletion.
10. Limitations
When creating a spec file using this interface, only the more popular X-12-ARIMA options are
available. To include any additional options, first create the spec and then edit it by hand.
11. Acknowledgements
This program was conceived and mainly written by Roxanne Feldpausch. Thanks also to
Christopher Blakely for his help in adding the Java graphs and to David Findley, Brian Monsell,
and Kathleen McDonald-Johnson for their suggestions and feedback.
The program's Java graphs are produced using the JFreeChart and JCommon libraries, (C)
opyright 2000- 2009 by Object Refinery Limited and Contributors. The libraries are covered by
the Lesser General Public Licence. The interface also uses the Explorer Tree Control by Jim
Parsells, covered by the Code Project Open License.

Return to index.
12. References
U.S. Census Bureau (2011). X-12-ARIMA Reference Manual, Version 0.3.
U.S. Census Bureau (2011). X-12-Graph: A SAS/GRAPH Program for X-12-ARIMA Output.
Return to index.

